Tag - CAS

Validación de dígito de control en un código CAS

En esta práctica explicamos que es el valor CAS y cómo se calcula el dígito de control. Es importante tener claro este primer paso para poder entender el funcionamiento de esta verificación.  El objetivo es verificar el valor del dígito de control de un código CAS completo. Por ejemplo si queremos verificar el código CAS del agua: 7732-18-5 deberíamos utilizar la función:   =SI(RESIDUO(EXTRAE(A1;LARGO(A1)-2;1)*1+EXTRAE(A1;LARGO(A1)-3;1)*2 +EXTRAE(A1;LARGO(A1)-5;1)*3+EXTRAE(A1;LARGO(A1)-6;1)*4 +SI.ERROR(EXTRAE(A1;LARGO(A1)-7;1);0)*5+SI.ERROR(EXTRAE(A1;LARGO(A1)-8;1);0)*6 +SI.ERROR(EXTRAE(A1;LARGO(A1)-9;1);0)*7+SI.ERROR(EXTRAE(A1;LARGO(A1)-10;1);0)*8 +SI.ERROR(EXTRAE(A1;LARGO(A1)-11;1);0)*9 +SI.ERROR(EXTRAE(A1;LARGO(A1)-12;1);0)*10;10) =VALOR(EXTRAE(A1;LARGO(A1);1));”CAS Correcto”;”CAS Incorrecto”)  La primera parte del SI realizaremos el cálculo del dígito de control a partir de los dígitos del CAS. Este valor [...]

Leer más…

Cómo calcular el dígito de control de un registro CAS

En primer lugar, definamos que es un número de registro CAS (Chemical Abstracts Service), es una identificación compuesta por números para compuestos químicos, polímeros, secuencias biológicas, preparados y aleaciones.  El registro CAS no tiene valor por si mismo, sino que se asigna en orden secuencial y está formado por tres partes separadas entre sí mediante guiones. La primera parte es un valor numérico entre dos y siete dígitos, la segunda tiene dos dígitos y la tercera es un dígito de control. De tal [...]

Leer más…